View unanswered posts | View active topics



Reply to topic  [ 2 posts ] 
No autocomplete nor syntax highlighting on core flash libs 
Author Message
Member

Joined: Sun Feb 08, 2015 7:53 pm
Posts: 7
Reply with quote
I recently had to format my C drive and consequently reinstall FlashDevelop.
Now, when opening my AS3 project the program doesn't seem to recognize basic Flash classes (such as Sprite and MovieClip from the flash.display library). What I mean is that it both doesn't do syntax highlighting nor autocomplete on them. Pressing F4 when standing on a flash class also doesn't do anything (previously it would show a version of the code without the actual implementation).

Image

As you can see from the image the "fl" library and my own custom classes do get syntax highlighted. Autocomplete also works for them.

It all compiles fine because I use Adobe Animate 2019 to compile. It's just super inconvenient!

Did I miss something in my installation of FlashDevelop? Are there some settings I need to change?


Sat Aug 17, 2019 8:10 am
Profile
Member

Joined: Sun Feb 08, 2015 7:53 pm
Posts: 7
Reply with quote
I just tried, but it also doesn't work if I start a new project from scratch.

EDIT: I also tried reinstalling Flashdevelop, which gave the same issue.

EDIT 2: I now reverted to Flashdevelop 4.7.2 and all issues disappeared. I guess it's just the later versions that are broken. Perhaps my setup simply wasn't up-to-date before my windows format.


Sat Aug 17, 2019 10:59 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.