View unanswered posts | View active topics



Reply to topic  [ 3 posts ] 
How To Install The Latest SDK? (30,31,32) ? 
Author Message
Member

Joined: Fri Feb 27, 2009 12:30 am
Posts: 34
Reply with quote
Some questions please...

1) The "Tools/Install Software" recognizes Flex 4.6.0+29.0.0 as the latest sdk, how do I install newer versions?

2) Currently I have 29 installed, but from the project properties I can only select up to SDK 28. How do I choose 29?

3) I'm using SDK 28, should I even be concerned about using the newer sdks? I've tested my app on my test devices and it's working fine.

4) I'm using FD 5.3.3.1 but the "Help/Check For Updates" never recognized the newer version (I was running 5.2.0) I had to visit this site manually to see a newer version was available.

Thank you for any help/comments.


Fri Nov 30, 2018 6:25 pm
Profile
Member

Joined: Fri Feb 27, 2009 12:30 am
Posts: 34
Reply with quote
ruh roh.... support for FlashDevelop finally gone? :(


Thu Dec 06, 2018 5:24 pm
Profile
Member

Joined: Wed Oct 28, 2015 4:06 pm
Posts: 9
Reply with quote
1) Download AIR SDK (manually)
https://www.adobe.com/devnet/air/air-sdk-download.html

2) Unzip and move SDK to
[local app data]\FlashDevelop\Apps\ascsdk\xx.x.x
x = SDK version numbers (e.g. 32.0.0) and it's root SDK folder (first level subfolders are bin, lib etc.)

3) Download playerglobal.swc (all versions)
https://helpx.adobe.com/flash-player/kb ... sions.html

4) Open folder
[local app data]\FlashDevelop\Apps\ascsdk\[SDK version]\frameworks\libs\player\

Create subfolders xx.x, where x = playerglobal version numbers (e.g. 11.4, 11.5 .... 32.0)
Move downloaded playerglobal files to folders by swc version and rename swc files to "playerglobal.swc".

5) Open folder
[program files]\FlashDevelop\Tools\flexlibs\frameworks\libs\player\

Copy here all subfolders from 4)

6) Open folder
[local app data]\FlashDevelop\Settings\Platforms\AS3\

Add lines with version values to: air.xml, airmobile.xml, flashplayer.xml
Line format is: <version value="xx.x" swf-version="yy" />

x = player / swc version numbers (e.g. 11.4, 11.5 .... 32.0)
y = target swf version, numbers are here
https://helpx.adobe.com/air/air-releasenotes.html
(AIR xx RELEASE NOTES >> Authoring Guidelines)

7) Open folder
[program files]\FlashDevelop\Settings\Platforms\AS3\

Copy here all files from 6)

8 ) Start FD, go to Settings >> AS3Context

"Installed Flex SDKs" - click "..." on right edge of line
Add new SDK. Path, name, version...use old SDK as example for values...

Move newest SDK at top of list. Top SDK is default for compilations.

9) Optional
Settings >> AS3Context >> Default Flash Version - set to newest
ASDoc - set newest SDK path to doc compiler

[local app data]\FlashDevelop\Projects\[some AS3 project]
[program files]\FlashDevelop\Projects\[some AS3 project]
Edit number in "Project.as3proj" tag <movie version> to newest SDK. It's default player version for new projects.


Sun Dec 16, 2018 11:51 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.