View unanswered posts | View active topics



Reply to topic  [ 17 posts ]  Go to page 1, 2  Next
[HELP ME] "The system cannot find the file specified" 
Author Message
Member

Joined: Fri Dec 24, 2010 7:59 pm
Posts: 17
Reply with quote
This is happened when I reinstall my windows xp, that means also installing the new flash develop, java, and flash player. When I started new project, compile that's okay there is no problem, after that I made a new project again compile, no problem. But when I was trying to compile again my old project there is a problem:

The compiling process is alright but after the compiling process finished it showed:
Image
:? :( :x :evil:

What should I do??

This is never happened before.

Thanks..
Sorry for my bad English..


Fri Dec 24, 2010 8:08 pm
Profile
Member

Joined: Fri Dec 24, 2010 7:59 pm
Posts: 17
Reply with quote
I have tried search on Google. I found this.
http://www.flashdevelop.org/community/viewtopic.php?f=13&t=4247

And got attention to this.
Image

I installed 32 bit Java.
I have changed the jvm.config, as instructed above.
Image
I changed line 27 to point jre folder. The save.

Btw, this is my jre directory.
Image

But Flashdevelop keeps return "The system cannot find the file specified".
It does not changed anything at all.

Anyone can help me.

Thanks for helping.
Sorry for my bad English.

Merry Christmas and Happy New Year all.


Thu Dec 30, 2010 8:30 am
Profile
Admin

Joined: Tue Aug 30, 2005 6:14 pm
Posts: 3061
Location: Finland
Reply with quote
You need to specify a flash player to open Swf files in Windows or specify a path to your standalone player in FlashViewer plugin settings.


Thu Dec 30, 2010 8:52 am
Profile WWW
Member

Joined: Fri Dec 24, 2010 7:59 pm
Posts: 17
Reply with quote
Mika wrote:
You need to specify a flash player to open Swf files in Windows or specify a path to your standalone player in FlashViewer plugin settings.

Thanks for your answer.

Image
I have already specified a flash player in windows.

Image
If you mean by specifying standalone flash player in flashviewer like this. Compiling is success, but it showed nothing.

Any idea? by the way this is happened when I re-install my windows, and re-install my flashdevelop again. This never happened before.


Thu Dec 30, 2010 9:38 am
Profile
Member

Joined: Wed Jun 20, 2007 8:09 am
Posts: 331
Reply with quote
Quick thought:
Is your SWF compiled for 10.1 and your Projector 10.0? That was a problem I ran into recently :evil:

Lg
warappa

_________________
Practice always defeats theory


Thu Dec 30, 2010 10:22 am
Profile WWW
Member

Joined: Fri Dec 24, 2010 7:59 pm
Posts: 17
Reply with quote
Warappa wrote:
Quick thought:
Is your SWF compiled for 10.1 and your Projector 10.0? That was a problem I ran into recently :evil:

Lg
warappa

Thanks

How to set it... the compiler and my projector? thanks

Nothing happened by the way. Still showed white blank screen.
But instead showing "The system cannot find the file specified" it says "[No debug Flash player connection request]"

Arrggggg :evil: :evil:


Thu Dec 30, 2010 11:14 am
Profile
Member

Joined: Wed Jun 20, 2007 8:09 am
Posts: 331
Reply with quote
Swf: Project Options -> Platform -> Target: Flash Player 10.1
Projector: ...
Wait a second: Do you want to compile a Flex Hero project? Then you SDK must be 4.5 AND the external Flash Projector must be from THAT SDK (your screenshot shows that you're currently using the projector from the 4.1 SDK) -> update the FlashViewer -> External Player to the 4.5 SDK and try again.

_________________
Practice always defeats theory


Thu Dec 30, 2010 12:23 pm
Profile WWW
Member

Joined: Fri Dec 24, 2010 7:59 pm
Posts: 17
Reply with quote
Warappa wrote:
Swf: Project Options -> Platform -> Target: Flash Player 10.1
Projector: ...
Wait a second: Do you want to compile a Flex Hero project? Then you SDK must be 4.5 AND the external Flash Projector must be from THAT SDK (your screenshot shows that you're currently using the projector from the 4.1 SDK) -> update the FlashViewer -> External Player to the 4.5 SDK and try again.

Thanks

Is that flex hero 4.5xx??
I just using the self download flex when installing flash develop.

Okay I will downloaded the flex hero then.

By the way which one that I must download?
Milestone or the hero build?


Thu Dec 30, 2010 1:45 pm
Profile
Admin

Joined: Wed Aug 31, 2005 7:27 am
Posts: 12172
Location: London
Reply with quote
It's probably not Flex Hero - just regular Flixel dev, your SDK is probably ok.

Mikael, what is your project's main class?
Does it have a green arrow icon in the Project panel?
If not, right-click on it > Always compile.

You may want to adjust the SWF dimensions also in the Project properties.


Thu Dec 30, 2010 3:48 pm
Profile WWW
Member

Joined: Fri Dec 24, 2010 7:59 pm
Posts: 17
Reply with quote
Philippe wrote:
It's probably not Flex Hero - just regular Flixel dev, your SDK is probably ok.

Mikael, what is your project's main class?
Does it have a green arrow icon in the Project panel?
If not, right-click on it > Always compile.

You may want to adjust the SWF dimensions also in the Project properties.

Thanks for your answer

I have adjusted the swf
Code:
[SWF(width = "640", height = "480", backgroundColor = "#000000")]


My main class named Main.as, and it already check listed as always compile.
I have this problem after I re-install windows, and install the newest FlashDevelop and newest Flex SDK (not the Flex Hero).

This just happened when I was trying to compile my older project. I not happened in my newest project.
I don't have any idea. I have searched over google and not find the answer. The guy that I find said that I must use 32 bit of Java, but it still not changed.

I need your help.


Thu Dec 30, 2010 4:57 pm
Profile
Member

Joined: Fri Dec 24, 2010 7:59 pm
Posts: 17
Reply with quote
Just report that as Phillipe said FlexHero does not solve this problem.

Flex Hero (when compiling)
Code:
Running process: C:\Program Files\FlashDevelop\Tools\fdbuild\fdbuild.exe "D:\my dojo\training\as3.0 flixel basic level structure finished on wednesday, 22 december 2010 at 21.42\As3.0 flixel basic level structure.as3proj" -ipc 9ddf7532-c110-413d-82e7-b6575270a5ae -compiler "C:\Program Files\FlashDevelop\flex_sdk_4.5.0.17689" -library "C:\Program Files\FlashDevelop\Library"
Exception: Could not locate lib\mxmlc.jar in Flex SDK. Please set the correct path to the Flex SDK in AS3Context plugin settings.
Done(1)


Thu Dec 30, 2010 6:11 pm
Profile
Member

Joined: Fri Dec 24, 2010 7:59 pm
Posts: 17
Reply with quote
Any idea? Anyone?


Fri Dec 31, 2010 8:03 am
Profile
Admin

Joined: Wed Aug 31, 2005 7:27 am
Posts: 12172
Location: London
Reply with quote
Can you check this new wiki doc to see if everything is in order?
http://www.flashdevelop.org/wikidocs/in ... :Debugging

Does your SWF work if you drag&drop it in a webbrowser?

Also when we say to check your SWF dimensions and FP target version, we mean to look into FlashDevelop Project Properties. In Main menu Project > Properties, or using the button in the Project panel toolbar.


Fri Dec 31, 2010 11:21 am
Profile WWW
Member

Joined: Fri Dec 24, 2010 7:59 pm
Posts: 17
Reply with quote
Philippe wrote:
Can you check this new wiki doc to see if everything is in order?
http://www.flashdevelop.org/wikidocs/in ... :Debugging

Does your SWF work if you drag&drop it in a webbrowser?

Also when we say to check your SWF dimensions and FP target version, we mean to look into FlashDevelop Project Properties. In Main menu Project > Properties, or using the button in the Project panel toolbar.

Thanks Philippe it works by the way.

It works only when I run it in Google Chrome. The standalone Flash Player still not working, but its okay.

Image
Image

This error still appeared (but nothing affected or I don't know which part is affected by):
Image

The man on Adobe forum said this:
Image
Quote:
Hi,

If you want to use the new fp 10.1 features I would recommend that you download the latest nightly build of the sdk, this includes features required for 10.1 and also has both both globalplayer swc's. You can then target then player 10.0.0 or 10.1.0 in the project settings.

Also make sure that the flashplayer 10.1 beta is correctly installed.

David.


Need I download the nightly build to replace the sdk that I have now?

I really appreciate your answer Philippe... Thanks and Happy New Year.

MikaelKristya.


Fri Dec 31, 2010 3:52 pm
Profile
Admin

Joined: Wed Aug 31, 2005 7:27 am
Posts: 12172
Location: London
Reply with quote
Keep Flex 4.1 regular SDK, this "get custom SWC" thing is most likely unrelated, and try again fixing your standalone player configuration: if it works in the browser but not in the standalone player then it means you have your config wrong.


Fri Dec 31, 2010 7:44 pm
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 17 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.