View unanswered posts | View active topics



Reply to topic  [ 2 posts ] 
Running my AS3 code? 
Author Message
Member

Joined: Tue Jun 14, 2011 11:52 pm
Posts: 4
New to FlashDevelop.
I've never coded ActionScript before, but I'm a strong Java developer.

I designed an ActionScript 3.0 socket that connects to my chat server, when I run the movie from the IDE, it works great.
However, I need to run my ActionScript socket from my browser, eg; an html document on my desktop.

I was surprised to not see any "Export Project" settings.
I looked in my Project folder, and found an Index.html, along with my socket in swf form, a preloader, and a Javascript file.
However when I run the Index.html, the socket doesn't connect to my server. I created a basic HTML document embedding my swf, but still no gold.

Could it be an issue with my socket code? If so how can I find any errors?
Bonus questions: What is a preloader? and would it be required to run my socket?

Thanks :)


Tue Jun 14, 2011 11:57 pm
Profile
Member

Joined: Tue Jun 14, 2011 11:52 pm
Posts: 4
No wait wait!

I guess I was mistaken.
For some reason it's working just fine now in all browsers.

It wasn't working earlier though.

Oh well. I guess if I run into anymore problems I'll post here again.


Wed Jun 15, 2011 1:02 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.