View unanswered posts | View active topics



Reply to topic  [ 84 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6
FD4- Debugger is not starting 
Author Message
Member

Joined: Thu Mar 27, 2008 2:13 pm
Posts: 211
Reply with quote
btw I cant connect to fp11.4b sad, using fd4.0.4rtm :S edit: disregard that, I downloaded sar, not sad.

_________________
Was seen using 4.0.4 RTM b2 rev. 2337 on Win7 .NET 2.0 on July 29th, 2012


Sat Jul 28, 2012 10:55 pm
Profile
Member

Joined: Thu Sep 06, 2012 5:38 pm
Posts: 1
Reply with quote
I have the same problem if I try to run an AIR project that uses Native Extensions via ADL: cannot place breakpoints anywhere, neither before nor during execution. If I remove the extension from the AIR properties window, it works.


Thu Sep 06, 2012 5:41 pm
Profile
Member

Joined: Thu Apr 24, 2008 2:29 pm
Posts: 61
Reply with quote
oh-oh I just updated to 4.2.0 and the debugger does not work anymore :( please help!

Debugger startup error: System.BadImageFormatException: An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B)
at net.sf.jni4net.jni.JNI.Dll.JNI_GetDefaultJavaVMInitArgs(JavaVMInitArgs* args)
at net.sf.jni4net.jni.JNI.Init()
at net.sf.jni4net.jni.JNI.CreateJavaVM(JavaVM& jvm, JNIEnv& env, Boolean attachIfExists, String[] options)
at net.sf.jni4net.Bridge.CreateJVM()
at net.sf.jni4net.Bridge.CreateJVM(BridgeSetup setup)
at FlashDebugger.DebuggerManager.Start(Boolean alwaysStart)
[Capturing traces with FDB]


Sat Nov 17, 2012 8:52 pm
Profile
Member

Joined: Thu Apr 24, 2008 2:29 pm
Posts: 61
Reply with quote
...


Last edited by nIg3D on Sat Nov 17, 2012 9:25 pm, edited 2 times in total.



Sat Nov 17, 2012 9:05 pm
Profile
Member

Joined: Thu Apr 24, 2008 2:29 pm
Posts: 61
Reply with quote
all right, nothing worked out. I think I have to stop coding for today

P.S.: ok finally found the solution...I had to point my java home to the 32 bit...however the previous version of flash develop I had installed was working fine with the 64bit version

P.P.S.:damn! now I remember what I did (I blogged about it as well!) I modified the jvm.config file grrr


Sat Nov 17, 2012 9:14 pm
Profile
Member

Joined: Tue Aug 30, 2011 1:22 pm
Posts: 50
Reply with quote
rakiner wrote:
I'd just like to add that I had this error on a fresh install of win7-64bit, and fixed it by copying C:\Program Files (x86)\Java\jre6\bin\msvcr71.dll to C:\Windows\SysWOW64

After a format i had the same problem. That solved it. Maybe that works with the newest java but haven't tried it yet.


Sun Nov 24, 2013 3:13 pm
Profile
Member

Joined: Sat Sep 21, 2013 2:27 pm
Posts: 3
Reply with quote
Copying msvcr71.exe to FlashDevelop's folder made debugger resurrect on my Win7_32 (just moved from WinXP). Thank you!


Tue Dec 24, 2013 5:11 am
Profile
Member

Joined: Tue Nov 08, 2005 4:05 pm
Posts: 1
Reply with quote
Did you ever resolve this - I cannot get working since my system forced an update from Windows 8 to 8.1?

Tried all the recommendations online around Java versions, Environment variables and copying dll's

Does anyone have working on win 8.1?


Wed Nov 26, 2014 1:50 pm
Profile
Admin

Joined: Wed Aug 31, 2005 7:27 am
Posts: 12172
Location: London
Reply with quote
On Win8/8.1, I removed all the Java SDKs I had, installed Java 1.7 32bits, restarted.
I didn't do any DLL manipulation.

I have path/to/Java/bin in the PATH and path/to/Java as JAVA_HOME

You can force JAVA_HOME by editing/creating a jvm.config file in path/to/FlexSDK/bin:
http://flashdevelop.org/community/viewt ... 602#p52602


Wed Nov 26, 2014 2:40 pm
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 84 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.