View unanswered posts | View active topics



Reply to topic  [ 2 posts ] 
playerglobal.swc path is broken 
Author Message
Member

Joined: Wed Feb 13, 2013 2:17 pm
Posts: 45
Reply with quote
Build halts with an error. This happens sort of randomly.

Project settings are to target FP 19, not 11.1 as seen in the error message.

Code:
Running process: C:\Program Files (x86)\FlashDevelop\Tools\fdbuild\fdbuild.exe "D:\xxx.as3proj" -ipc xxx -version "19.0.0" -compiler "C:\Users\xxx\AppData\Local\FlashDevelop\Apps\ascsdk\19.0.0_241" -library "C:\Program Files (x86)\FlashDevelop\Library"
Building xxx
mxmlc-cli -load-config="C:\Users\xxx\AppData\Local\FlashDevelop\Apps\ascsdk\19.0.0_241/frameworks/flex-config.xml" -load-config+=obj\xxxConfig.xml -debug=true -advanced-telemetry=true -inline=true -swf-version=30 -o obj\xxx635975318768353818
Running java as: java.exe
Loading configuration: C:\Users\xxx\AppData\Local\FlashDevelop\Apps\ascsdk\19.0.0_241\frameworks\flex-config.xml
Loading configuration: D:\FDWorkspace\xxx\obj\xxxConfig.xml

C:\Users\xxx\AppData\Local\FlashDevelop\Apps\ascsdk\19.0.0_241\frameworks\flex-config.xml:47:Error: unable to open 'C:\Users\xxx\AppData\Local\FlashDevelop\Apps\ascsdk\19.0.0_241\frameworks\libs\player\11.1\playerglobal.swc'.
C:\Users\xxx\AppData\Local\FlashDevelop\Apps\ascsdk\19.0.0_241\frameworks\flex-config.xml (line: 47)
        </external-library-path>

Build halted with errors (mxmlc-cli).

Here is part of the flex-config.xml:

Code:
<flex-config>

    <!-- Specifies the minimum player version that will run the compiled SWF. -->
    <target-player>19.0</target-player>

    <compiler>

        <!-- List of path elements that form the roots of ActionScript class hierarchies. -->
        <!-- not set -->
        <!--
            <source-path>
                <path-element>string</path-element>
            </source-path>
        -->

        <!-- Allow the source-path to have path-elements which contain other path-elements -->
        <allow-source-path-overlap>false</allow-source-path-overlap>

        <!-- Turn on generation of debuggable SWFs. False by default for mxmlc, -->
        <!-- but true by default for compc. -->
        <!--
            <debug>true</debug>
        -->

        <!-- List of SWC files or directories to compile against but to omit from -->
        <!-- linking. -->
        <external-library-path>
            <path-element>libs/player/{targetPlayerMajorVersion}.{targetPlayerMinorVersion}/playerglobal.swc</path-element>
        </external-library-path>

This bug has been aroud for quite a while, any chance it could be fixed ? :)


Fri Apr 29, 2016 11:31 am
Profile
Member

Joined: Wed Feb 13, 2013 2:17 pm
Posts: 45
Reply with quote
Bumping this as it's a recurring issue. Could this be fixed?


Mon Jun 06, 2016 11:35 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.