View unanswered posts | View active topics



Reply to topic  [ 81 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next
FlashBuild Plugin Releases [1.0 Beta 1] 
Author Message
Admin

Joined: Wed Aug 31, 2005 7:27 am
Posts: 12172
Location: London
Post 
robertpenner wrote:
tangent wrote:
I have been under the weather and I apologize for getting back soon. Thanks for trying out the latest release of FlashBuild 0.8. Robert and Evl, is it possible that I can get a copy of your FlashBuild.xml so I can quickly find out what could have caused the error?

I'm working on a different machine now and am not getting that error. However, the FlashBuild buttons are being disabled after one click, so I have to restart FD in order to use it again. Please, please, remove any code that would disable the panel. This was a showstopper a few months ago, but it has popped up again.

Was the other machine running Win2k? We had to embed explicitely all PNG resources in FD because of crashes on Win2k when we embedded things in ImageLists.


Fri May 26, 2006 6:55 am
Profile WWW
Member

Joined: Tue Feb 14, 2006 10:42 pm
Posts: 72
Location: Canada
Post 
Both machines are WinXP SP2. I am actually getting the same error popup "Error while reading the file:" now on the other machine, since I started using the "Test Movie" button in the FlashBuild panel.

In regards to the other issue, the disabling, when I press the "Test Movie" button, the combo box and the Build button become grayed out and stay that way. If I press the Build button instead (after restarting FlashDevelop to reset the panel), both buttons and the combo box are grayed out.

These two issues occur with the downloaded 0.8 DLL from SourceForge. The icon resources issue I mentioned in a different thread is related only to trying to build FlashBuild myself with SharpDevelop.


Fri May 26, 2006 11:56 pm
Profile WWW
Member

Joined: Thu Sep 08, 2005 8:32 pm
Posts: 301
Location: Virginia
Post 
I am pleased to announce that FlashBuild 0.9 supports two additional compile options: Flash IDE compile and Flex 2.

To add Flash IDE compile support, simply add the follow snippet to your FlashBuild.xml, at the same level as the mtasc tag.

Code:
<!--
   Flash Ide compile
   You may supply either an Fla or Jsfl file.  If both files are supplied, only Fla is used
-->
<flashide>
   <setting key="Fla">path/to/file.fla</setting>
   <setting key="Jsfl">path/to/file.jsfl</setting>
</flashide>



To add Flex 2 compile, use the following snippet.
Code:
<flex2>
   <!-- Input mxml or as file -->
   <setting key="Input"></setting>

   <!--
      Most other Flex2 compiler parameters with single values should be supplied as:
            
   <setting key="OptionName">optionValue</setting>
            
   If there are any dashes "-" or dots "." in the Option Name, they should be taken away.  For example:
            
   <setting key="LoadConfig">path/to/my.config</setting>
            
   If an option can have multiple instances such as "includes", it should be coded as
            
   <setting key="Includes">
      <value>path1</value>
      <value>path2</value>
   </setting>
   -->
</flex2>


Sun Jul 16, 2006 7:23 am
Profile YIM WWW
Member

Joined: Mon Dec 26, 2005 6:10 pm
Posts: 165
Post 
Not having much luck with the flashide compile.

If I specify the fla, it does compile it, but does so using publish movie, so I can't see the results. Even if I specify the swf name in testMovie, it does not open up after compiling.

If I create a jsfl file and just use that instead of the fla, Flashopens up and says it can't find the jsfl file. It's looking in H: volume which I think is mapped to temp or something on my machine.


Fri Jul 21, 2006 2:39 pm
Profile
Member

Joined: Thu Sep 08, 2005 8:32 pm
Posts: 301
Location: Virginia
Post 
I have noticed the issue, and am going to post a fix soon.


Fri Jul 21, 2006 2:51 pm
Profile YIM WWW
Member

Joined: Mon Dec 26, 2005 6:10 pm
Posts: 165
Post 
Similarly, if I set up flex 2 project. It compiles the swf just fine and if I open it, it's correct. But if I target that swf in testMovie, it opens a tab and tries to load the swf, but fails in loading. Seems like a timing thing.


Fri Jul 21, 2006 3:34 pm
Profile
Member

Joined: Mon Dec 26, 2005 6:10 pm
Posts: 165
Post 
A quick fix for the flex 2 build I just found is to just add a postProcess tag, and put in the name of the swf. This launches it in a separate window.


Fri Jul 21, 2006 3:42 pm
Profile
Member

Joined: Mon Dec 26, 2005 6:10 pm
Posts: 165
Post 
Can't get a lot of compiler params to work.

defaultbackgroundcolor
defaultsize

I removed the dashes like the comments say. tried different forms of capitalization. Nothing.

oddly, defaultframerate works fine.

I argue for keeping the params EXACTLY as they are used in the command line compiler. I don't want to have to figure out how I'm supposed to tranform what it says in the docs into something that flashbuild will understand.


Fri Jul 21, 2006 4:11 pm
Profile
Member

Joined: Sun Mar 05, 2006 4:48 pm
Posts: 40
Location: San Francisco
Post 
Thanks. I've compiled my first Flex app in FlashDevelop. I documented the steps here on my blog: http://www.pasz.com/blog/2006/07/compil ... d-and.html

I had make one adjustment to the default settings:
Code:
<setting key="generateframeloader">true</setting>


Otherwise I'd get the following error during compilation.
Error: Unable to resolve a class for factoryClass: _MyFirst_mx_managers_SystemManager.

No idea what this means, since I'm new to this Flex stuff, but there you go. :)


Sat Jul 29, 2006 3:54 pm
Profile WWW
Member

Joined: Thu Sep 08, 2005 8:32 pm
Posts: 301
Location: Virginia
Post 
Adam, I am pretty new to Flex, and I have built FlashBuild support according to Adobe's documentation. There is a quick way you can try and see what might have gone wrong -- FlashBuild generates FlashBuild.bat each time you run it, you can open the bat file, and fiddle with the switch until it works for you. This will help narrow down the problem.

Since Flex has so many switches and I have noticed some possible errors on Adobe's documentation, it will be helpful that we can hunt those down.

By the way, the GUI version of FlashBuild with full support of Flex2 is in the works. I will post some screenshots later.


Sun Jul 30, 2006 4:38 am
Profile YIM WWW
Member

Joined: Thu Sep 08, 2005 8:32 pm
Posts: 301
Location: Virginia
Post 
An early screenshot of FlashBuild GUI

Image


Wed Aug 02, 2006 2:13 am
Profile YIM WWW
Member

Joined: Thu Sep 08, 2005 8:32 pm
Posts: 301
Location: Virginia
Post 
I have updated FlashBuild to 1.0 Beta 1 which sports a GUI for editing convenience. I have dropped PreProcess and PostProcess in favor of Shell command execution.

Happy Flash Building, and please excuse the rough GUI, yet your feedbacks are very important.


Fri Aug 04, 2006 4:17 pm
Profile YIM WWW
Admin

Joined: Wed Aug 31, 2005 7:27 am
Posts: 12172
Location: London
Post 
It's becoming good, really :)

My remarks:

- it always offers to create a build file - maybe it should be an option (disabled by default?) as it can be selected in the menu. And what about a template with a minimum build file?

- I feel the full-white background is a bit disturbing... What about some #eeeeee or #f8f8f8 background?

- the scrollbar in the advanced panel is cropped (the panel is too large, Windows XP classic) and the layout doesn't update if I resize the right or left panels,
- the advanced section is confusing (too much options) - maybe you can manage how to create settings groups and move some obvious options (like Output file) in the QuickStart tab.

But again: that's awesome and very light compared to ANT!


Mon Aug 07, 2006 8:46 pm
Profile WWW
Member

Joined: Sun Mar 05, 2006 4:48 pm
Posts: 40
Location: San Francisco
Post 
Quote:
- it always offers to create a build file - maybe it should be an option (disabled by default?) as it can be selected in the menu.

Yes, this is quite annoying. So annoying, in fact, that I had to remove FlashBuild for the time being. :(


Sat Aug 12, 2006 2:23 pm
Profile WWW
Member

Joined: Thu Sep 08, 2005 8:32 pm
Posts: 301
Location: Virginia
Post 
I will address the annoyance in the next release.


Mon Aug 14, 2006 5:59 am
Profile YIM WWW
Display posts from previous:  Sort by  
Reply to topic   [ 81 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.