View unanswered posts | View active topics



Reply to topic  [ 7 posts ] 
Error trying to run first plugin and SamplePlugin 
Author Message
Member

Joined: Wed Feb 04, 2009 3:22 pm
Posts: 184
Location: Scottsdale, AZ
Reply with quote
Hey everyone,

I'm getting this error when i try to run my plugin that I'm working on. It's my first one.

Code:
Severity   Code   Description   Project   File   Line   Suppression State
Error      The command ""D:\development\flashdevelop\External\Plugins\MerchantSwitcher\MerchantSwitcher\\SetVersion.bat" "D:\development\flashdevelop\External\Plugins\MerchantSwitcher\MerchantSwitcher\" && ^
IF EXIST "D:\development\flashdevelop\FlashDevelop\Bin\Debug\FlashDevelop.exe" move /Y "D:\development\flashdevelop\FlashDevelop\Bin\Debug\FlashDevelop.exe" "D:\development\flashdevelop\FlashDevelop\Bin\Debug\FlashDevelop86.exe"" exited with code 9009.   FlashDevelop


I also get the same error when running the SamplePlugin in the repo.

I'm pretty new to Visual Studio too, though not to programming in general.

Any help is appreciatecd!

THanks


Sat Aug 20, 2016 9:41 pm
Profile YIM WWW
Member

Joined: Wed Feb 04, 2009 3:22 pm
Posts: 184
Location: Scottsdale, AZ
Reply with quote
It appears that the FlashDevelop.exe can't be found.

I have added the existing FlashDevelop project to my solution and set it as the startup project. But I can't seem to get FlashDevelop project to build.


Sat Aug 20, 2016 9:46 pm
Profile YIM WWW
Member

Joined: Wed Feb 04, 2009 3:22 pm
Posts: 184
Location: Scottsdale, AZ
Reply with quote
Ah OK it looks like it's looking for SetVersion.bat within my plugin folder instead of where it's at in the flashdevelop folder. But I'm not sure why it's looking there or how to fix it.


Sat Aug 20, 2016 11:07 pm
Profile YIM WWW
Member

Joined: Wed Feb 04, 2009 3:22 pm
Posts: 184
Location: Scottsdale, AZ
Reply with quote
I finally got it compiling.

But now I'm getting an error that it can't load an incompatible plugin. But I don't really know why it's incompatible. It doesnt give any more information


Sat Aug 20, 2016 11:33 pm
Profile YIM WWW
Member

Joined: Wed Feb 04, 2009 3:22 pm
Posts: 184
Location: Scottsdale, AZ
Reply with quote
https://dl.dropboxusercontent.com/u/1814797/MerchantSwitcher.zip

Here is my plugin. There's really nothing in it yet. It's completely bare bones. But still not working


Sun Aug 21, 2016 3:51 am
Profile YIM WWW
Member

Joined: Wed Feb 04, 2009 3:22 pm
Posts: 184
Location: Scottsdale, AZ
Reply with quote
Shows that I'm a noob. I figured it out. I needed to compile my plugin for .NET 3.5. I guess 4.5.2 isn't compatible with 3.5? Or does flashdevelop make a check for the .NET vesrion on plugins and restrict them?


Sun Aug 21, 2016 12:23 pm
Profile YIM WWW
Moderator

Joined: Mon Jul 06, 2009 8:14 am
Posts: 258
Reply with quote
Yeah, FD is compiled for .NET 3.5, so it cannot use plugins written in .NET 4.0+... For Windows it would be completely safe to build FD in any newer .NET version, but it should be tested if it's working 100% fine under CrossOver.

The first problem you mentioned with VS not being able to find FlashDevelop.exe is surely because you were running targetting AnyCPU. I don't know if it's possible to detect if you are running or building... if it is, when running we could not rename the final executable to FlashDevelop64.exe.

Regarding SetVersion.bat, it gets some data from .git to set the build version, it should be made more robust so it doesn't make the build to fail if there is not .git folder.

Last, and more important, welcome to FD, and hope you'll become a nice contributor!


Mon Aug 22, 2016 8:48 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.