View unanswered posts | View active topics



Reply to topic  [ 4 posts ] 
Theme Difference Help 
Author Message
Member

Joined: Fri Jan 21, 2011 5:17 am
Posts: 75
Reply with quote
If I can discover how to attach files to this request, I will attach two screen shots. One will show an open project in FlashDevelop 5.3, the other will show a comparable open project in HaxeDevelop 5.3. Both tools configurations are set to use the same Full Theme -- TheyleusThemeV2.

In case I am unable to attache the screen shots, let me just explain that while the two displays are almost identical -- indeed the contents of the CURRENT file under Settings for both are exactly identical -- in the HaxeDevelop case the background of the panel which displays the source code is dark chocolate, whereas in the FlashDevelop case the background of the panel is white.

I suppose this means that the theme is not controlling the background color of the main panel, but I cannot find what configuration setting is doing that. It is very difficult to read and write code in a panel with a chocolate background even though the text has somehow been change to light yellow!

Where do I control the appearance of the code. It is nice that the two different IDEs are so similar, but it appears that there is a plugin called Code Analyzer in FlashDev [which may have settings for the color of the text and the background], but no similar plugin HaxeDev.


Thu Dec 07, 2017 9:06 pm
Profile
Admin

Joined: Tue Aug 30, 2005 6:14 pm
Posts: 3046
Location: Finland
Reply with quote
You can log this to github where you can attach images. Based on your description it seems you have syntax theme applied from different theme for some reason or maybe its broken.

We have different theme files for ui and editor window. CURRENT holds the last applied ui theme and \Settings\Languages\*.xml are the lang config and coloring files for the editor. They are patched when you apply a new full or syntax theme.


Fri Dec 08, 2017 12:30 pm
Profile WWW
Member

Joined: Fri Jan 21, 2011 5:17 am
Posts: 75
Reply with quote
This was most likely a cockpit error on my part. After several re-starts, I am now seeing the same appearance using the ThyleusV2 theme whether opening a project in Release 5.3 of FlashDevelop or HaxeDevelop.


Mon Dec 11, 2017 10:35 pm
Profile
Admin

Joined: Tue Aug 30, 2005 6:14 pm
Posts: 3046
Location: Finland
Reply with quote
Great :)


Tue Dec 12, 2017 11:53 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.