View unanswered posts | View active topics



Reply to topic  [ 2 posts ] 
FlashDevelop 3.0.0 RC1 released 
Author Message
Admin

Joined: Tue Aug 30, 2005 6:14 pm
Posts: 3032
Location: Finland
:!: This is an old version of the program, please check the releases page for the latest version.

Merry Christmas and a Happy New Year!

It's again Christmas time and here is our present for you. This release is quite big due to Vista x64 problems that we had and a pile of new features that we implemented into this release.
This also caused that previous FlashDevelop versions are incompatible with this one but from here on, we will try to preserve all user settings, templates and snippets. Sorry for the trouble.

As we are now approaching the final release of FlashDevelop 3, this release also means a code freeze for the PluginCore so if you develop plugins for flashdevelop rebuild them against this release
and they should be fully compatible from here on unless you heavily rely to the default plugins. Some changes may occur there.

About FlashDevelop:

* Features
* Screenshots

Changes:

* Live syntax errors highlighting (AS3).
* The editor font can now be defined in the settings.
* Automatic type selection after "new" with typed vars.
* Explorer shell menu has been added to "Files" and "Project" panels.
* Smart contextual event type completion, if declared with Event() directive.
* You can double-click on a class when exploring a library SWC to see the class model.
* Completion automatically adapts to the project's Flash Player target version (FP9, FP10, AIR).
* External SWC's (outside of the project tree) now appear like external classpaths.
* Updated MXML completion, now with effects attributes.

+ Lots of bug fixes and other small improvements. :)

Future plans:

* Finish the AS3 debugger, investigate profiling.
* Add HTML/JS projects, investigate Jangaroo AS to JS compilation.
* Make the MXML completion actually smart.

Important:

* Backup your user files and uninstall FlashDevelop with setting files. From this point on we'll preserve the user files so please customize the files again based on this release.
* Get Adobe Flex 3 SDK. The free Flex SDK (2 or 3) is required for ActionScript 3 development if you don't use Flash CS3.
* Get the debug Flash Player (You need: Projector and ActiveX)
* Java 1.6+ is required for the Flex compiler (ActionScript 3).

:!: If you think the program is good, please donate some money for this project. :!:

Download:

Built from rev. 264
Download FlashDevelop 3.0.0 RC1


Tue Dec 23, 2008 9:21 pm
Profile WWW
Admin

Joined: Wed Aug 31, 2005 7:27 am
Posts: 12162
Location: London
Known issues:

Code completion files have been rewritten for FP9/FP10 support and they contain a few errors (for instance get/set appear as simple properties). This will be fixed asap but we need your feedback if you find mistakes.


Sat Dec 27, 2008 10:35 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.