View unanswered posts | View active topics



Reply to topic  [ 1 post ] 
FlashDevelop 5.3.0 released 
Author Message
Admin

Joined: Tue Aug 30, 2005 6:14 pm
Posts: 3040
Location: Finland
Reply with quote
Howdy folks! We are still very active but could not come up with a proper release until now due to large downtime with our core devs.

This release is a large one due to the highly active contributors, lots of fixes and improvements and new features included. Once again as this is a major release we will follow up with minor releases asap if needed and big thanks go to our awesome contributors and supporters!

HaxeDevelop is a custom distribution of FlashDevelop for Haxe devs. Read more at: http://www.haxedevelop.org.

Note to customizers:

* FD5 is compatible with FD4 but we highly suggest doing a clean install when coming from FD4.
* You should only use syntax themes made for FD 4.3+

Features, fixes and improvements: (changes)

- Update to .NET 4.0
- AIR27 and FP27 lib updates
- Haxe hxml project import added
- Code completion and generation improvements
- Full theming support added with one new theme
- Overall UI usability and perf improvements
- SourceControl improvements
- Diagnostics completion added
- Multiple results panel support added
- Clipboard history support added
- Dynamic batch processor
- Linting manager added

+ Gazillion other fixes and improvements

NOTE: Some translations are partly out of date.

Contributor credits:

See: https://github.com/fdorg/flashdevelop/g ... ntributors

Important:

* Microsoft .NET 4.0 runtime is now required
* You can install SDK's and other related software from the AppMan (Tools -> Install Software...)
* Java 1.6+ 32-bits is required for the Flex compiler and the Debugger for ActionScript 3 development.
* SourceControl plugin depends on TortoiseSVN and TortoiseGit.

:!: If you think the program is good, please donate some money for this project. :!:

Image

Download: (Build 3)

Download FlashDevelop 5.3.0 Setup
Download FlashDevelop 5.3.0 Zip

Install for Mac and Linux with CrossOver:
NOTE: .NET 4.0 needs to be manually installed until new installer is accepted
https://www.codeweavers.com/compatibili ... p_id=13502

Mac/Linux native helper (Bridge v2):
http://www.flashdevelop.org/wikidocs/in ... tle=Bridge


Mon Nov 13, 2017 7:20 pm
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.