View unanswered posts | View active topics



Reply to topic  [ 1 post ] 
FlashDevelop 4.4.3 RTM released 
Author Message
Admin

Joined: Tue Aug 30, 2005 6:14 pm
Posts: 3040
Location: Finland
Reply with quote
:!: This is an old version of the program, please check the releases page for the latest version.

We are now back from our summer holidays and working on the next major version of FD. Before that, this release fixes issues found after the previous major release and adds few new feats. Enjoy!

If you are updating from releases prior to 4.0.0 Beta, see it's release notes here

Note to customizers:

* FD4 is not compatible with FD3 plugins and requires a clean install when coming from FD3 or FD4 beta releases.
* You should only use syntax themes made for FD 4.3+

Features, fixes and improvements: (changes)

* Loom bug fixes and improvents
* AIR SDK 3.8 and FP 11.8 update
* Added SevenZip SDK to PluginCore
* Haxe modules support in completion
* Added -inline compiler option for ASC2
* Completion bug fixes and improvements in AS, Haxe & CSS/Less
* Added embedded webserver (nekotools) for NME/OpenFL HTML5 and as new Test Movie option
* Fixed syntax checking when using ASC2 (using asc fallback)
* OpenFL support & NME/OpenFL project templates added
* QuickBuild correctly resolve -size-report relatively to project
* Matching Flash CC error reporting syntax
* Flash debugger support for SWF reloading
* TaskPanel is fixed and now runs manually
* Basic support for @inheritDoc added

+ Lots of smaller improvements and fixes

Contributor credits:

* ir73 & zobo: Constant work on the debugger and the code generation
* Griz & bkzen & Josu & wanghehacker: Localization
* JoeyRobichaud: SplitView patch

Mac/Linux virtualization:

* Native helper (Bridge): viewtopic.php?f=9&t=7621
* This is an ALPHA quality feature

Future plans:

* Evaluate TypeScript support
* Good mobile projects integration
* Complete project solutions

Important:

* Microsoft .NET 2.0 SP1 runtime is really required, even if you already have .NET 4.0 installed.
* Get the ActiveX (for IE) Debug Flash Player. This is required by the browser control.
* Get the free Adobe Flex SDK. The free Adobe Flex SDK (2, 3 or 4) is required for ActionScript 3 development if you don't use Flash CS*.
* FlashDevelop setup will offer automatically download Adobe Flex SDK and this is highly recommended.
* Java 1.6+ 32-bits is required for the Flex compiler and the Debugger for ActionScript 3 development.
* SourceControl plugin depends on TortoiseSVN and TortoiseGit.

:!: If you think the program is good, please donate some money for this project. :!:

Download:

Built from rev. 2784
Download FlashDevelop 4.4.3 RTM

Additional downloads:

* Legacy AS2 project templates
* 3rd party plugins


Wed Sep 04, 2013 7:09 pm
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.