View unanswered posts | View active topics



Reply to topic  [ 1 post ] 
FlashDevelop 4.4.1 RTM released 
Author Message
Admin

Joined: Tue Aug 30, 2005 6:14 pm
Posts: 3034
Location: Finland
:!: This is an old version of the program, please check the releases page for the latest version.

This release fixes issues found after the previous major release. Enjoy!

If you are updating from releases prior to 4.0.0 Beta, see it's release notes here

Note to customizers:

* FD4 is not compatible with FD3 plugins and requires a clean install when coming from FD3 or FD4 beta releases.
* You should only use syntax themes made for FD 4.3+

Features, fixes and improvements: (changes)

* Safer check for ASC.jar
* AIR Flash Player version fix
* Installer fixes and improvements
* MXML support disabled in AS3 fixed
* Fix for ambiguous class names in SWCs
* Get class model from SWF disabled fixed
* Make sure AS3 file masks are always valid
* Debugger LiveDataTip null handling improvement
* Added missing icons for Android packaging to templates
* Template hint added about "depthandstencil" AIR option
* Loom .lsproj added to the Open Project dialog filter
* Extract Loom docs from loomlibs for completion
* Capture Loom compiler errors
* Loom file lock issue fixed

+ Build updated to rev. 2668 after two hours from initial release with missing IPhone 5 splash screens

Contributor credits:

* ir73 & zobo: Constant work on the debugger and the code generation
* Griz & bkzen & Josu & wanghehacker: Localization

Mac/Linux virtualization:

* Native helper (Bridge): viewtopic.php?f=9&t=7621
* This is an ALPHA quality feature

Future plans:

* Evaluate TypeScript support
* Good mobile projects integration
* Complete project solutions

Important:

* Microsoft .NET 2.0 SP1 runtime is really required, even if you already have .NET 4.0 installed.
* Get the ActiveX (for IE) Debug Flash Player. This is required by the browser control.
* Get the free Adobe Flex SDK. The free Adobe Flex SDK (2, 3 or 4) is required for ActionScript 3 development if you don't use Flash CS*.
* FlashDevelop setup will offer automatically download Adobe Flex SDK and this is highly recommended.
* Java 1.6+ 32-bits is required for the Flex compiler and the Debugger for ActionScript 3 development.
* SourceControl plugin depends on TortoiseSVN and TortoiseGit.

:!: If you think the program is good, please donate some money for this project. :!:

Download:

Built from rev. 2667 (Build updated to 2668 after two hours from initial release)
Download FlashDevelop 4.4.1 RTM

Additional downloads:

* Legacy AS2 project templates
* 3rd party plugins


Mon May 13, 2013 7:27 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 1 post ] 

Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.